v1.0.0 Excessive False Positives

Incident Report for Conceal

Resolved

We have confirmed that these issues are resolved in ConcealBrowse v1.1.3, which is available for Chrome in the Chrome Store.

For RCA inquiries, please reach out to support@conceal.io
Posted Mar 12, 2024 - 11:17 EDT

Update

Conceal version 1.1.3 has officially been approved and published to the Chrome Extension store. Please upgrade to this latest version to resolve the issues you have been experiencing.
Posted Mar 08, 2024 - 05:52 EST

Monitoring

Excessive false positives reported by multiple customers using Chrome. Interim fix has been implemented in Conceal back end until permanent fix is available in v1.1.3 (pending store approval).
Posted Mar 07, 2024 - 14:06 EST