Microsoft Edge 130.x bug running certain extensions

Incident Report for Conceal

Resolved

This issue is fixed in Microsoft Edge stable release 130.0.2849.56
Posted Oct 28, 2024 - 09:23 EDT

Identified

We have discovered an issue with the most recent release of Microsoft Edge.

Edge version: All 130 versions
Operating System: Scope unknown

Where Edge will fail to consistently run extensions that use Managed storage.

Microsoft is aware and tracking this issue. The current suggested workaround for this issue is to roll back to at least 129.0.2792.89.

https://learn.microsoft.com/en-us/deployedge/microsoft-edge-known-issues
Posted Oct 23, 2024 - 16:54 EDT